<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" 
	prefix="og: https://ogp.me/ns#" >
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="profile" href="http://gmpg.org/xfn/11">
    <link rel="pingback" href="https://www.eclectablog.com/xmlrpc.php">

    <title>Don&#039;t just praise the heroes, PAY the heroes – with special guest U.S. Senator Gary Peters | Eclectablog</title>

<!-- All In One SEO Pack 3.4.3[412,541] -->
<meta name="description"  content="Senator Gary Peters on Twitter: @GaryPeters and @SenGaryPeters Peters Announces Coronavirus &quot;Heroes Fund&quot; Proposal, Calls for $25,000 Pay Increase for Essential" />

<meta name="keywords"  content="gary peters,podcast,senator gary peters" />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.eclectablog.com/#organization","url":"https://www.eclectablog.com/","name":"Eclectablog","sameAs":["https://twitter.com/Eclectablog","http://www.facebook.com/Eclectablog","https://plus.google.com/u/0/108360887539865528997/posts"]},{"@type":"WebSite","@id":"https://www.eclectablog.com/#website","url":"https://www.eclectablog.com/","name":"Eclectablog","publisher":{"@id":"https://www.eclectablog.com/#organization"}},{"@type":"WebPage","@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#webpage","url":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html","inLanguage":"en-US","name":"Don't just praise the heroes, PAY the heroes - with special guest U.S. Senator Gary Peters","isPartOf":{"@id":"https://www.eclectablog.com/#website"},"breadcrumb":{"@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#breadcrumblist"},"image":{"@type":"ImageObject","@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#primaryimage","url":"https://www.eclectablog.com/wp-content/uploads/2018/09/GOTMFV-for-social-media.png","width":1200,"height":800},"primaryImageOfPage":{"@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#primaryimage"},"datePublished":"2020-05-18T13:48:53-04:00","dateModified":"2020-05-18T13:50:37-04:00"},{"@type":"Article","@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#article","isPartOf":{"@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#webpage"},"author":{"@id":"https://www.eclectablog.com/author/eclectablog#author"},"headline":"Don&#8217;t just praise the heroes, PAY the heroes &#8211; with special guest U.S. Senator Gary Peters","datePublished":"2020-05-18T13:48:53-04:00","dateModified":"2020-05-18T13:50:37-04:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#webpage"},"publisher":{"@id":"https://www.eclectablog.com/#organization"},"articleSection":"Gary Peters, Podcast, Gary Peters, Podcast, Senator Gary Peters","image":{"@type":"ImageObject","@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#primaryimage","url":"https://www.eclectablog.com/wp-content/uploads/2018/09/GOTMFV-for-social-media.png","width":1200,"height":800}},{"@type":"Person","@id":"https://www.eclectablog.com/author/eclectablog#author","name":"Eclectablog","sameAs":[],"image":{"@type":"ImageObject","@id":"https://www.eclectablog.com/#personlogo","url":"https://secure.gravatar.com/avatar/bca8470945210233b1dc6aae1bedc732?s=96&d=mm&r=pg","width":96,"height":96,"caption":"Eclectablog"}},{"@type":"BreadcrumbList","@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.eclectablog.com/","url":"https://www.eclectablog.com/","name":"Eclectablog"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html","url":"https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html","name":"Don't just praise the heroes, PAY the heroes - with special guest U.S. Senator Gary Peters"}}]}]}</script>
<link rel="canonical" href="https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Don&#039;t just praise the heroes, PAY the heroes – with special guest U.S. Senator Gary Peters | Eclectablog" />
<meta property="og:description" content="Senator Gary Peters on Twitter: @GaryPeters and @SenGaryPeters Peters Announces Coronavirus &quot;Heroes Fund&quot; Proposal, Calls for $25,000 Pay Increase for Essential Workers on Frontlines of Pand" />
<meta property="og:url" content="https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html" />
<meta property="og:site_name" content="Eclectablog" />
<meta property="og:image" content="https://www.eclectablog.com/wp-content/uploads/2018/09/GOTMFV-for-social-media-1024x683.png" />
<meta property="fb:admins" content="616546096" />
<meta property="fb:app_id" content="1517516405161415" />
<meta property="article:published_time" content="2020-05-18T13:48:53Z" />
<meta property="article:modified_time" content="2020-05-18T13:50:37Z" />
<meta property="og:image:secure_url" content="https://www.eclectablog.com/wp-content/uploads/2018/09/GOTMFV-for-social-media-1024x683.png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Eclectablog" />
<meta name="twitter:domain" content="Eclectablog" />
<meta name="twitter:title" content="Don&#039;t just praise the heroes, PAY the heroes – with special guest" />
<meta name="twitter:description" content="Senator Gary Peters on Twitter: @GaryPeters and @SenGaryPeters Peters Announces Coronavirus &quot;Heroes Fund&quot; Proposal, Calls for $25,000 Pay Increase for Essential Workers on Frontlines of Pand" />
<meta name="twitter:image" content="https://www.eclectablog.com/wp-content/uploads/2018/09/GOTMFV-for-social-media-1024x683.png" />
<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.eclectablog.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='scap.flashblock-css'  href='https://www.eclectablog.com/wp-content/plugins/compact-wp-audio-player/css/flashblock.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='scap.player-css'  href='https://www.eclectablog.com/wp-content/plugins/compact-wp-audio-player/css/player.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='flick-css'  href='https://www.eclectablog.com/wp-content/plugins/mailchimp//css/flick/flick.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimpSF_main_css-css'  href='https://www.eclectablog.com/?mcsf_action=main_css&#038;ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<!--[if IE]>
<link rel='stylesheet' id='mailchimpSF_ie_css-css'  href='https://www.eclectablog.com/wp-content/plugins/mailchimp/css/ie.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='wpapp-styles-css'  href='https://www.eclectablog.com/wp-content/plugins/wordpress-easy-paypal-payment-or-donation-accept-plugin/wpapp-styles.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.eclectablog.com/wp-includes/css/dist/block-library/style.min.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='wp-components-css'  href='https://www.eclectablog.com/wp-includes/css/dist/components/style.min.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-font-css'  href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C400i%2C700%2C700i&#038;ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-editor-css'  href='https://www.eclectablog.com/wp-includes/css/dist/block-editor/style.min.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='wp-nux-css'  href='https://www.eclectablog.com/wp-includes/css/dist/nux/style.min.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-css'  href='https://www.eclectablog.com/wp-includes/css/dist/editor/style.min.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-style-css-css'  href='https://www.eclectablog.com/wp-content/plugins/author-avatars/blocks/dist/blocks.style.build.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://www.eclectablog.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.8' type='text/css' media='all' />
<style id='contact-form-7-inline-css' type='text/css'>
.wpcf7 .wpcf7-recaptcha iframe {margin-bottom: 0;}.wpcf7 .wpcf7-recaptcha[data-align="center"] > div {margin: 0 auto;}.wpcf7 .wpcf7-recaptcha[data-align="right"] > div {margin: 0 0 0 auto;}
</style>
<link rel='stylesheet' id='jquery-ui-style-css'  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/ui-darkness/jquery-ui.css?ver=1.11.4' type='text/css' media='all' />
<link rel='stylesheet' id='zoom-theme-utils-css-css'  href='https://www.eclectablog.com/wp-content/themes/magazinum/functions/wpzoom/assets/css/theme-utils.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='magazinum-style-css'  href='https://www.eclectablog.com/wp-content/themes/magazinum/style.css?ver=4.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='media-queries-css'  href='https://www.eclectablog.com/wp-content/themes/magazinum/css/media-queries.css?ver=4.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.eclectablog.com/wp-includes/css/dashicons.min.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='magazinum-google-font-default-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C400italic%2C700%2C700italic&#038;subset=latin%2Clatin-ext%2Cvietnamese%2Ccyrillic-ext%2Cgreek-ext&#038;ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-widget-css'  href='https://www.eclectablog.com/wp-content/plugins/author-avatars/css/widget.css?ver=2.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://www.eclectablog.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-theme-css'  href='https://www.eclectablog.com/wp-content/themes/magazinum/styles/light.css?ver=edb6e431ac5b8d0e3e3a8be0afa62a6b' type='text/css' media='all' />
<link rel='stylesheet' id='wpzoom-custom-css'  href='https://www.eclectablog.com/wp-content/themes/magazinum/custom.css?ver=4.0.8' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-shortcode-css'  href='https://www.eclectablog.com/wp-content/plugins/author-avatars/css/shortcode.css?ver=2.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='https://www.eclectablog.com/wp-content/plugins/slideshow-gallery/views/default/css/colorbox.css?ver=1.3.19' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://www.eclectablog.com/wp-content/plugins/slideshow-gallery/views/default/css/fontawesome.css?ver=4.4.0' type='text/css' media='all' />
<script src="https://www.eclectablog.com/wp-content/cache/minify/0ca7b.js"></script>





<script type='text/javascript'>
/* <![CDATA[ */
var mailchimpSF = {"ajax_url":"https:\/\/www.eclectablog.com\/"};
/* ]]> */
</script>
<script src="https://www.eclectablog.com/wp-content/cache/minify/d8874.js"></script>







<link rel='https://api.w.org/' href='https://www.eclectablog.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.eclectablog.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.eclectablog.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Why &#8220;Closet Conservatives&#8221; are Dangerous, and How to Spot Them' href='https://www.eclectablog.com/2020/05/why-closet-conservatives-are-dangerous-and-how-to-spot-them.html' />

<link rel='shortlink' href='https://www.eclectablog.com/?p=71601' />
<link rel="alternate" type="application/json+oembed" href="https://www.eclectablog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.eclectablog.com%2F2020%2F05%2Fdont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.eclectablog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.eclectablog.com%2F2020%2F05%2Fdont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html&#038;format=xml" />
<script type="text/javascript">
        jQuery(function($) {
            $('.date-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd/yyyy';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: true,
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').addClass('show'); },
                    dateFormat: format.toLowerCase(),
                });
            });
            d = new Date();
            $('.birthdate-pick').each(function() {
                var format = $(this).data('format') || 'mm/dd';
                format = format.replace(/yyyy/i, 'yy');
                $(this).datepicker({
                    autoFocusNextInput: true,
                    constrainInput: false,
                    changeMonth: true,
                    changeYear: false,
                    minDate: new Date(d.getFullYear(), 1-1, 1),
                    maxDate: new Date(d.getFullYear(), 12-1, 31),
                    beforeShow: function(input, inst) { $('#ui-datepicker-div').removeClass('show'); },
                    dateFormat: format.toLowerCase(),
                });

            });

        });
    </script>
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
<!-- WPZOOM Theme / Framework -->
<meta name="generator" content="Magazinum 4.0.8" />
<meta name="generator" content="WPZOOM Framework 1.9.0" />
<style type="text/css">a{color:#813030;}
body{font-size: 16px;}.post h2.entry_title a{font-size: 26px;font-weight: bold;}</style>
<script src='https://www.google.com/recaptcha/api.js'></script>

<meta name="google-site-verification" content="cm7DWiMU8DRJ8RsSlHeZPFhLJCwQvM9GtZYu1uSl6o0" /><script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
	<link rel="icon" href="https://www.eclectablog.com/wp-content/uploads/2018/06/cropped-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.eclectablog.com/wp-content/uploads/2018/06/cropped-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.eclectablog.com/wp-content/uploads/2018/06/cropped-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.eclectablog.com/wp-content/uploads/2018/06/cropped-favicon-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

#footer {
    background: #FFF;
    color: #000;
		border-top: 1px solid #E0E0E0;
}

#footer .widget a {
    color: #000;
}

#copyright a {
    color: #000;
}

#footer .widget h3.title {
    color: #000;
}

.top-navbar {
    background: #fff;
    padding: 0 10px;
    position: relative;
    z-index: 101;
		border-bottom: 1px solid #E0E0E0;
}

.top-navbar a {
	color: #000;
}

.top-navbar ul a:hover {
    background: #B8CBE3;
}

.main-navbar ul a {
    background: #fff;
	  color: #1a1a1a;
    font-size: 18px;
    font-weight: bold;
    position: relative;
}

.main-navbar ul a:hover {
    background: #B8CBE3;
}

.main-navbar .sfHover a {
    background: #fff;
}

#carousel {
    background: #B8CBE3 url(images/bg_carousel.png) repeat-x top;
    overflow: hidden;
    padding: 15px 30px 0;
    position: relative;
    border-bottom: 1px solid #E0E0E0;
}

.main-navbar {
    background: #ffffff;
	  border-bottom: 1px solid #E0E0E0;
	  border-top: 1px solid #E0E0E0;
}

.navbar-toggle .icon-bar {
    background: #000;
}

.entry blockquote {
 	border-left:3px solid #CCCCCC;
	color:#575757;
 	font-size:16px;
	font-style:italic;
	line-height:1.8em;
	margin:10px 20px 10px 30px;
	padding-left:10px;
}

.entry img {
	margin-right: 8px;
	margin-bottom: 2px;
}

.adv {
    float: right;
    margin: 30px 10px 10px 0;
}		</style>
		
    </head>


<body class="post-template-default single single-post postid-71601 single-format-standard custom-background">

<div class="page-wrap">

	<div class="inner-wrap">

		<div id="header">

			<nav class="top-navbar" role="navigation">

                <div class="header_social">
                    
                </div>

	            <div class="navbar-header">
	                	                    <a class="navbar-toggle" href="#menu-top-slide">
	                        <span class="icon-bar"></span>
	                        <span class="icon-bar"></span>
	                        <span class="icon-bar"></span>
	                    </a>

                        <div id="menu-top-slide" class="menu-top-bar-menu-container"><ul id="menu-top-bar-menu" class="menu"><li id="menu-item-38207" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38207"><a href="https://www.eclectablog.com/contact-eclectablog">Contact (tips, comments, etc.)</a></li>
<li id="menu-item-23776" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23776"><a href="https://www.eclectablog.com/eclectablog-comment-policy">Comment Policy</a></li>
<li id="menu-item-33861" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33861"><a href="https://www.eclectablog.com/privacy-policy">Privacy policy</a></li>
<li id="menu-item-49933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49933"><a href="https://www.eclectablog.com/subscribeunsubscribe-to-post-notification-emails">Email subscribe/unsubscribe</a></li>
</ul></div>
	            </div>


	            <div id="navbar-top">

	                <div class="menu-top-bar-menu-container"><ul id="menu-top-bar-menu-1" class="nav navbar-nav dropdown sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38207"><a href="https://www.eclectablog.com/contact-eclectablog">Contact (tips, comments, etc.)</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23776"><a href="https://www.eclectablog.com/eclectablog-comment-policy">Comment Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33861"><a href="https://www.eclectablog.com/privacy-policy">Privacy policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49933"><a href="https://www.eclectablog.com/subscribeunsubscribe-to-post-notification-emails">Email subscribe/unsubscribe</a></li>
</ul></div>

	            </div><!-- #navbar-top -->

	        </nav><!-- .top-navbar -->


			<div id="logo">
				
					<a href="https://www.eclectablog.com" title="Progressive News and Commentary">
													<img src="http://www.eclectablog.com/wp-content/uploads/2016/02/simple_logo_eclectablog.png" alt="Eclectablog" />
											</a>

					        </div>


							<div class="adv">

											<a href="https://www.eclectablog.com/"><img src="https://www.eclectablog.com/wp-content/uploads/2016/02/testimonials.png" alt="Homepage" /></a>
					
				</div><!-- /.adv -->
			


			
			<div class="clear"></div>

			<nav class="main-navbar" role="navigation">

	            <div class="navbar-header">
	                
	                    <a class="navbar-toggle" href="#menu-main-slide">
	                        <span class="icon-bar"></span>
	                        <span class="icon-bar"></span>
	                        <span class="icon-bar"></span>
	                    </a>

                        <div id="menu-main-slide" class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-60633" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-60633"><a href="https://www.eclectablog.com/category/podcast">Podcast</a></li>
<li id="menu-item-69560" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69560"><a href="https://firebetsydevos.com/">Betsy DeVos</a></li>
<li id="menu-item-22118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22118"><a href="https://www.eclectablog.com/category/emergency-managers">Emergency Managers</a></li>
<li id="menu-item-57245" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-57245"><a href="https://www.eclectablog.com/tag/flint-water-crisis">Flint Water Crisis</a></li>
<li id="menu-item-59255" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-59255"><a href="https://www.eclectablog.com/tag/trans-stories">#TransStories</a></li>
<li id="menu-item-61280" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-61280"><a href="https://www.eclectablog.com/tag/aca-stories">ACA stories</a></li>
</ul></div>
	            </div>


	            <div id="navbar-main">

	                <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="nav navbar-nav dropdown sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-60633"><a href="https://www.eclectablog.com/category/podcast">Podcast</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69560"><a href="https://firebetsydevos.com/">Betsy DeVos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22118"><a href="https://www.eclectablog.com/category/emergency-managers">Emergency Managers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-57245"><a href="https://www.eclectablog.com/tag/flint-water-crisis">Flint Water Crisis</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-59255"><a href="https://www.eclectablog.com/tag/trans-stories">#TransStories</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-61280"><a href="https://www.eclectablog.com/tag/aca-stories">ACA stories</a></li>
</ul></div>

	            </div><!-- #navbar-main -->

	        </nav><!-- .main-navbar -->


  			<div class="clear"></div>
 		</div><!-- /#header -->
<div id="content">

	<div id="post-71601" class="post-71601 post type-post status-publish format-standard has-post-thumbnail hentry category-gary-peters category-podcast tag-gary-peters tag-podcast tag-senator-gary-peters">

		
			<div class="meta">
 				<a href="https://www.eclectablog.com/category/gary-peters" rel="category tag">Gary Peters</a>, <a href="https://www.eclectablog.com/category/podcast" rel="category tag">Podcast</a>				 &mdash; May 18, 2020 at 9:48 am				<span></span>
			</div>

  			<h1 class="title"><a href="https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html" rel="bookmark" title="Permanent Link to Don&#8217;t just praise the heroes, PAY the heroes &#8211; with special guest U.S. Senator Gary Peters">Don&#8217;t just praise the heroes, PAY the heroes &#8211; with special guest U.S. Senator Gary Peters</a></h1>

			<span class="author">by <a href="https://www.eclectablog.com/author/eclectablog" title="Posts by Eclectablog" rel="author">Eclectablog</a></span>
			<div class="entry">
 				<div class="at-above-post addthis_tool" data-url="https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html"></div><p>Senator Gary Peters on Twitter: <a href="https://twitter.com/GaryPeters" rel="noopener noreferrer" target="_blank">@GaryPeters</a> and <a href="https://twitter.com/SenGaryPeters" rel="noopener noreferrer" target="_blank">@SenGaryPeters</a></p>
<p><a href="https://www.peters.senate.gov/newsroom/press-releases/peters-announces-coronavirus-heroes-fund-proposal-calls-for-25000-pay-increase-for-essential-workers-on-frontlines-of-pandemic-response" rel="noopener noreferrer" target="_blank">Peters Announces Coronavirus “Heroes Fund” Proposal, Calls for $25,000 Pay Increase for Essential Workers on Frontlines of Pandemic Response</a></p>
<p><a href="https://www.peters.senate.gov/newsroom/press-releases/peters-air-force-must-immediately-prioritize-pfas-cleanup-efforts-at-former-wurtsmith-base-in-oscoda" rel="noopener noreferrer" target="_blank">Peters: Air Force Must Immediately Prioritize PFAS Cleanup Efforts at Former Wurtsmith Base in Oscoda</a></p>
<p>Make a donation to make sure Gary Peters keeps his seat in the U.S. Senate at <a href="https://petersformichigan.com/" rel="noopener noreferrer" target="_blank">PetersForMichigan.com</a>.</p>
<hr>
<p>Progressives Everywhere on Twitter: <a href="https://twitter.com/Progressives50" target="_blank" rel="noopener noreferrer">@Progressives50</a></p>
<p><iframe src="https://player.blubrry.com/id/60754778/" scrolling="no" width="100%" height="138px" frameborder="0"></iframe></p>
<p>Help Progressives Everywhere help elect <a href="https://www.ennekingforflorida.com/" rel="noopener noreferrer" target="_blank">Kayser Enneking</a>, a candidate for the State House of Representatives in Florida&#8217;s 21st House District <a href="https://secure.actblue.com/donate/progressiveseverywhere" rel="noopener noreferrer" target="_blank">HERE</a> and to support service workers and artists impacted by the coronavirus epidemic by clicking <a href="https://www.gofundme.com/f/coronavirus-relief-help-service-workers-amp-artists" rel="noopener noreferrer" target="_blank">HERE</a>.</p>
<p>Sign up for Jordan&#8217;s newsletter <i>Pandemic Stories</i> <a href="https://pandemicstories.substack.com/" rel="noopener noreferrer" target="_blank">HERE</a>.</p></blockquote>
<p>Progressives Everywhere&#8217;s website: <a href="https://progressiveseverywhere.org/" target="_blank" rel="noopener noreferrer">ProgressivesEverywhere.org</a></p>
<p>Support Progressives Everywhere by becoming a Patreon donor <a href="https://www.patreon.com/ProgressivesEverywhere">HERE</a>.</p>
<p><img src="https://www.eclectablog.com/wp-content/uploads/2018/12/Election-Calendar.png" width="350" align="right" />Jordan&#8217;s important project: <a href="https://election-calendar.com/" target="_blank" rel="noopener noreferrer">Election-Calendar.com</a></p>
<hr />
<p>Give us a five-star review <a href="https://itunes.apple.com/us/podcast/sit-spin-room-lolgop-eclectablog/id1164243223?mt=2" target="_blank" rel="noopener noreferrer">at iTunes</a>!</p>
<p>The GOTMFV Show Facebook page is <a href="https://www.facebook.com/TheGOTMFVShow/" target="_blank" rel="noopener noreferrer">HERE</a>!</p>
<p><b>Music clips</b><br />
Intro and transition music: <a href="https://www.youtube.com/watch?v=jF-QQ885UqA" target="_blank" rel="noopener noreferrer">You Dress Like an Asshole</a> by <a href="http://notthe1s.com/" target="_blank" rel="noopener noreferrer">Not The 1s</a><br />
Progressives Everywhere intro/outro: <a href="https://www.youtube.com/watch?v=aC551c5upgI" target="_blank" rel="noopener noreferrer">They&#8217;re Everywhere</a> by Jim&#8217;s Big Ego<br />
Outro music: <a href="https://www.youtube.com/watch?v=YZXFdikh-70">Complain</a> (from the movie <i>Bob Roberts</i>) by David Robbins &amp; Tim Robbins</p>
<iframe src="https://player.blubrry.com/?media_url=https%3A%2F%2Fmedia.blubrry.com%2Fsitandspinshow%2Fp%2Fcontent.blubrry.com%2Fsitandspinshow%2FGOTMFV_Show-Episode_98.mp3&amp;podcast_link=https%3A%2F%2Fwww.eclectablog.com%2F2020%2F05%2Fdont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html" scrolling="no" width="100%" height="138px" frameborder="0" id="blubrryplayer-1" class="blubrryplayer"></iframe><p class="powerpress_links powerpress_links_mp3">Podcast: <a href="https://media.blubrry.com/sitandspinshow/p/content.blubrry.com/sitandspinshow/GOTMFV_Show-Episode_98.mp3" class="powerpress_link_pinw" target="_blank" title="Play in new window" onclick="return powerpress_pinw('https://www.eclectablog.com/?powerpress_pinw=71601-podcast');" rel="nofollow">Play in new window</a> | <a href="https://media.blubrry.com/sitandspinshow/s/content.blubrry.com/sitandspinshow/GOTMFV_Show-Episode_98.mp3" class="powerpress_link_d" title="Download" rel="nofollow" download="GOTMFV_Show-Episode_98.mp3">Download</a></p><p class="powerpress_links powerpress_subscribe_links">Subscribe: <a href="https://itunes.apple.com/us/podcast/sit-spin-room-lolgop-eclectablog/id1164243223?mt=2&amp;ls=1#episodeGuid=https%3A%2F%2Fwww.eclectablog.com%2F%3Fp%3D71601" class="powerpress_link_subscribe powerpress_link_subscribe_itunes" title="Subscribe on Apple Podcasts" rel="nofollow">Apple Podcasts</a> | <a href="https://subscribeonandroid.com/www.eclectablog.com/feed/podcast" class="powerpress_link_subscribe powerpress_link_subscribe_android" title="Subscribe on Android" rel="nofollow">Android</a> | <a href="https://subscribebyemail.com/www.eclectablog.com/feed/podcast" class="powerpress_link_subscribe powerpress_link_subscribe_email" title="Subscribe by Email" rel="nofollow">Email</a> | <a href="https://www.google.com/podcasts?feed=aHR0cHM6Ly93d3cuZWNsZWN0YWJsb2cuY29tL2ZlZWQvcG9kY2FzdA" class="powerpress_link_subscribe powerpress_link_subscribe_googleplay" title="Subscribe on Google Podcasts" rel="nofollow">Google Podcasts</a> | <a href="http://www.stitcher.com/podcast/eclectablog/the-sit-and-spin-room-with-lolgop-eclectablog" class="powerpress_link_subscribe powerpress_link_subscribe_stitcher" title="Subscribe on Stitcher" rel="nofollow">Stitcher</a> | <a href="http://tunein.com/radio/The-Sit-and-Spin-Room-with-LOLGOP-p920386/" class="powerpress_link_subscribe powerpress_link_subscribe_tunein" title="Subscribe on TuneIn" rel="nofollow">TuneIn</a> | <a href="https://www.eclectablog.com/feed/podcast" class="powerpress_link_subscribe powerpress_link_subscribe_rss" title="Subscribe via RSS" rel="nofollow">RSS</a></p><!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://www.eclectablog.com/2020/05/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html"></div><!-- AddThis Share Buttons generic via filter on the_content --> 				<div class="clear"></div>
   			</div>

  			
			<div class="tags_list">Tags <a href="https://www.eclectablog.com/tag/gary-peters" rel="tag">Gary Peters</a> <a href="https://www.eclectablog.com/tag/podcast" rel="tag">Podcast</a> <a href="https://www.eclectablog.com/tag/senator-gary-peters" rel="tag">Senator Gary Peters</a></div>

							<div class="post_author">
					<img alt='Eclectablog' src='http://www.eclectablog.com/wp-content/uploads/2018/03/Eclectablog_avatar_1522285414-70x70.jpg' class='avatar avatar-70 photo' height='70' width='70' />					<span>Author: <a href="https://www.eclectablog.com/author/eclectablog" title="Posts by Eclectablog" rel="author">Eclectablog</a></span>
					<b>Chris Savage is the owner and publisher of Eclectablog</b>, your one-stop shop for progressive state &amp; national political news &amp; commentary.					<div class="clear"></div>
				</div>
			


			
<div id="disqus_thread"></div>


			</div> <!-- /.post -->
</div><!-- /#content -->
<div id="sidebar">
 
 			<div class="ads">
		
							<a href=""><img src="" alt="" /></a>
					   	
				
		</div><!-- /.ads -->
	 
 	<div id="search-3" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://www.eclectablog.com/">
    <label>
        <span class="screen-reader-text">Search for:</span>
        <input type="search" class="search-field" placeholder="Search …" value="" name="s" title="Search for:" />
    </label>
    <input type="submit" class="search-submit" value="Search" />
</form><div class="clear"></div></div><div id="wp_paypal_payment_widgets" class="widget widget_wp_paypal_payment"><h3 class="title">Help support nearly ad-free blogging at Eclectablog</h3><div id="accept_paypal_payment_form"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" class="wp_accept_pp_button_form_classic"><input type="hidden" name="cmd" value="_xclick" /><input type="hidden" name="business" value="eclectablog@gmail.com" /><input type="hidden" name="item_name" value="With YOUR support, all regular contributors at Eclectablog are paid for their work. If you would like to send a check to avoid fees being taken out, send it to: Chris Savage, P.O. Box 32, Dexter, MI 48130. Otherwise, you can use this Paypal form:" /><input type="hidden" name="currency_code" value="USD" /><div class="wpapp_payment_subject"><span class="payment_subject"><strong>With YOUR support, all regular contributors at Eclectablog are paid for their work. If you would like to send a check to avoid fees being taken out, send it to: Chris Savage, P.O. Box 32, Dexter, MI 48130. Otherwise, you can use this Paypal form:</strong></span></div><select id="amount" name="amount" class=""><option value="75">Basic supporter - $75</option><option value="125">Gold level supporter - $125</option><option value="250">Platinum level supporter - $250</option></select><div class="wpapp_other_amount_label"><strong>Other Amount:</strong></div><div class="wpapp_other_amount_input"><input type="number" min="1" step="any" name="other_amount" title="Other Amount" value="" class="wpapp_other_amt_input" style="max-width:80px;" /></div><input type="hidden" name="no_shipping" value="0" /><input type="hidden" name="no_note" value="1" /><input type="hidden" name="bn" value="TipsandTricks_SP" /><input type="hidden" name="return" value="http://www.eclectablog.com" /><div class="wpapp_payment_button"><input type="image" src="https://www.paypal.com/en_US/i/btn/btn_paynowCC_LG.gif" name="submit" alt="Make payments with payPal - it's fast, free and secure!" /></div></form></div><script type="text/javascript">
jQuery(document).ready(function($) {
    $('.wp_accept_pp_button_form_classic').submit(function(e){
        var form_obj = $(this);
        var other_amt = form_obj.find('input[name=other_amount]').val();
        if (!isNaN(other_amt) && other_amt.length > 0){
            options_val = other_amt;
            //insert the amount field in the form with the custom amount
            $('<input>').attr({
                type: 'hidden',
                id: 'amount',
                name: 'amount',
                value: options_val
            }).appendTo(form_obj);
        }		
        return;
    });
});
</script><div class="clear"></div></div><div id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><form action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_top">
<input type="hidden" name="cmd" value="_s-xclick">
<input type="hidden" name="hosted_button_id" value="C74UQ298H44TA">
<table>
<tr><td><b>Want to make a recurring monthly donation?</b> Enter the amount you want to pay each month:</td></tr><tr><td>$<input type="text" name="max_amount" value="">
USD</td></tr></table>
<table><tr><td align=center><i>Sign up for</i></td></tr><tr><td><input type="image" src="https://www.paypalobjects.com/en_US/i/btn/btn_auto_billing_CC_LG.gif" border="0" name="submit" alt="PayPal - The safer, easier way to pay online!"></td></tr></table>
<img alt="" border="0" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif" width="1" height="1">
</form></div><div class="clear"></div></div><div id="custom_html-6" class="widget_text widget widget_custom_html"><h3 class="title">LOLGOP on Twitter</h3><div class="textwidget custom-html-widget"><a class="twitter-timeline" href="https://twitter.com/LOLGOP " data-widget-id="699327230359560192">Tweets by @LOLGOP</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div><div class="clear"></div></div><div id="s2_form_widget-4" class="widget s2_form_widget"><h3 class="title">Subscribe to FREE email notifications!</h3><div class="search">Subscribe to or unsubscribe from free email notifications when new posts are posted.<br /><form name="s2formwidget" method="post" action="https://www.eclectablog.com/email-notification-acknowledgement-page"><input type="hidden" name="ip" value="107.23.218.4" /><span style="display:none !important"><label for="firstname">Leave This Blank:</label><input type="text" id="firstname" name="firstname" /><label for="lastname">Leave This Blank Too:</label><input type="text" id="lastname" name="lastname" /><label for="uri">Do Not Change This:</label><input type="text" id="uri" name="uri" value="http://" /></span><p><label for="s2email">Your email:</label><br><input type="email" name="email" id="s2email" value="Enter email address..." size="20" onfocus="if (this.value === 'Enter email address...') {this.value = '';}" onblur="if (this.value === '') {this.value = 'Enter email address...';}" /></p><p><input type="submit" name="subscribe" value="Subscribe" />&nbsp;<input type="submit" name="unsubscribe" value="Unsubscribe" /></p></form>
</div><div class="clear"></div></div><div id="text-51" class="widget widget_text"><h3 class="title">Subscribe to a free email daily digest</h3>			<div class="textwidget">If you'd like to receive one email per day with a list of all the previous day's posts, click <a href="https://feedburner.google.com/fb/a/mailverify?uri=Eclectablog&amp;loc=en_US">HERE</a>. NOTE: If you were subscribed prior to October 2016, you will need to resubscribe. This service is free.</div>
		<div class="clear"></div></div><div id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="fb-like-box" data-href="https://www.facebook.com/Eclectablog" data-colorscheme="light" data-show-faces="true" data-header="true" data-stream="false" data-show-border="true"></div></div><div class="clear"></div></div><div id="author_avatars-2" class="widget widget_author_avatars"><h3 class="title">Team Eclectablog</h3><div class="author-list"><div class="user nickname-group-c with-nickname user-1 with-biography bio-length-" style=""><a href="https://www.eclectablog.com/author/eclectablog" title="Chris"><span class="avatar"><img src='http://www.eclectablog.com/wp-content/uploads/2018/03/Eclectablog_avatar_1522285414-96x96.jpg' class='avatar avatar-96 photo' height='96' width='96' alt="avatar for Chris"  style=""  /></span><span class="name"><strong>Chris</strong></span></a><div class="biography"><p><b>Chris Savage is the owner and publisher of Eclectablog</b>, your one-stop shop for progressive state &amp; national political news &amp; commentary.</p>
</div></div><div class="user nickname-group-j with-nickname user-4 with-biography bio-length-" style=""><a href="https://www.eclectablog.com/author/lolgop" title="Jason"><span class="avatar"><img src='http://eclectablog.com/wp-content/uploads/2012/07/LOLGOP_avatar.png' class='avatar avatar-96 photo' height='96' width='96' alt="avatar for Jason"  style=""  /></span><span class="name"><strong>Jason</strong></span></a><div class="biography"><p><b>Contributor</b> - "Social media's latest political satire sensation" - <i><a href="http://www.politico.com/blogs/bensmith/1111/On_the_left_a_new_Twitter_favorite.html">Politico.com</a></i><br />
"FALSE" - <i><a href="http://www.politifact.com/truth-o-meter/article/2012/jan/04/farewell-michele-bachmann/">Politifact.com</a></i> -<br />
<b>Buy LOLGOP's book <a href="http://itunes.apple.com/us/book/the-drama-kids/id382529043?mt=11">HERE</b></a></p>
</div></div><div class="user nickname-group-a with-nickname user-9 with-biography bio-length-" style=""><a href="https://www.eclectablog.com/author/amy-lynn-smith" title="Amy Lynn Smith"><span class="avatar"><img alt='Amy Lynn Smith' src='http://www.eclectablog.com/wp-content/uploads/2017/02/Amy-Lynn-Smith_avatar_1487118288-96x96.jpg' class='avatar avatar-96 photo' height='96' width='96' style=""  /></span><span class="name"><strong>Amy Lynn Smith</strong></span></a><div class="biography"><p><b>Amy Lynn Smith</b> is a writer and communication strategist. Find her at <a href="http://www.alswrite.com">alswrite.com</a> or on Twitter at <a href="https://twitter.com/alswrite">@alswrite</a>.</p>
</div></div><div class="user nickname-group-m with-nickname user-18 with-biography bio-length-" style=""><a href="https://www.eclectablog.com/author/mitchell-robinson" title="Mitchell Robinson"><span class="avatar"><img alt='Mitchell Robinson' src='http://www.eclectablog.com/wp-content/uploads/2016/09/Mitchell-Robinson_avatar_1473512760-96x96.jpg' class='avatar avatar-96 photo' height='96' width='96' style=""  /></span><span class="name"><strong>Mitchell Robinson</strong></span></a><div class="biography"><p>Mitchell Robinson is associate professor and chair of music education at Michigan State University. His research is focused on music education and education policy. Follow him on Facebook <a href="https://www.facebook.com/mrobmsu">HERE</a> and Twitter at <a href="https://twitter.com/@mrobmsu">@mrobmsu</a>. His own blog is at <a href="http://mitchellrobinson.net">MitchellRobinson.net</a>.</p>
</div></div><div class="user nickname-group-a with-nickname user-6 with-biography bio-length-" style=""><a href="https://www.eclectablog.com/author/anne" title="Anne"><span class="avatar"><img src='http://eclectablog.com/wp-content/uploads/2012/07/Anne-Savage_avatar.jpg' class='avatar avatar-96 photo' height='96' width='96' alt="avatar for Anne"  style=""  /></span><span class="name"><strong>Anne</strong></span></a><div class="biography"><p><b><a href="http://annesavagephotography.com">Anne Savage</a> is a professional photographer</b> and contributor to Eclectablog.</p>
</div></div><div class="user nickname-group-b with-nickname user-3 with-biography bio-length-" style=""><a href="https://www.eclectablog.com/author/brainwrap" title="Brainwrap"><span class="avatar"><img src='http://eclectablog.com/wp-content/uploads/2012/07/Eclectablog_avatar-96x96.jpg' class='avatar avatar-96 photo' height='96' width='96' alt="avatar for Brainwrap"  style=""  /></span><span class="name"><strong>Brainwrap</strong></span></a><div class="biography"><p><b>Charles Gaba ("Brainwrap")</b> is the Eclectablog web hosting provider and an occasional contributor.</p>
</div></div><div class="user nickname-group-a with-nickname user-23 with-biography bio-length-" style=""><a href="https://www.eclectablog.com/author/ammara" title="Ammara"><span class="avatar"><img alt='Ammara Ansari' src='http://www.eclectablog.com/wp-content/uploads/2018/06/Ammara_Ansari-96x96.jpg' class='avatar avatar-96 photo' height='96' width='96' style=""  /></span><span class="name"><strong>Ammara</strong></span></a><div class="biography"><p>Ammara Ansari recently graduated with her Masters in Public Policy from the University of Michigan. She loves cats. Please note that her views are all her own and do not reflect any organization or entity with which she is associated.</p>
</div></div><div class="user nickname-group-b with-nickname user-24 with-biography bio-length-" style=""><a href="https://www.eclectablog.com/author/barb-byrum" title="Barb Byrum"><span class="avatar"><img alt='Barb Byrum' src='https://www.eclectablog.com/wp-content/uploads/2020/01/Clerk-Barb-Byrum-96x96.png' class='avatar avatar-96 photo' height='96' width='96' style=""  /></span><span class="name"><strong>Barb Byrum</strong></span></a><div class="biography"><p>Barb Byrum is currently in her second term as Ingham County Clerk, serving as the county’s chief elections official. As Clerk, Barb has successfully conducted 23 elections, 4 union elections, and currently serves on Michigan’s Election Security Commission, the Secretary of State’s team of advisors tasked with strengthening and better securing elections in the state. Follow her on Twitter at <a href="https://twitter.com/BarbByrum">@BarbByrum</a>.</p>
</div></div></div><div class="clear"></div></div><div id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://twitter.com/Eclectablog" class="twitter-follow-button" data-show-count="false" data-size="large">Follow @Eclectablog</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></div><div class="clear"></div></div><div id="linkcat-2" class="widget widget_links"><h3 class="title">Blogroll</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://bloggingblue.com/" title="Blogging liberally in the Badger State" target="_blank">Blogging Blue</a></li>
<li><a href="http://www.burntorangereport.com/" title="Best state blog in Texas" target="_blank">Burnt Orange Report</a></li>
<li><a href="https://crooked.com/" title="Pod will save everything" target="_blank">Crooked Media</a></li>
<li><a href="http://www.dailykos.com/" target="_blank">Daily Kos</a></li>
<li><a href="http://deepstatenation.com/" title="Matt Osborne&#8217;s blog">DeepStateNation.com</a></li>
<li><a href="http://www.democracy-tree.com/" target="_blank">Democracy Tree</a></li>
<li><a href="http://dianeravitch.net/" target="_blank">Diane Ravitch&#039;s blog</a></li>
<li><a href="http://www.emptywheel.net/" target="_blank">emptywheel</a></li>
<li><a href="http://glisteningquiveringunderbelly.blogspot.com/" title="Shining a light on the dark underbelly of fraud, cons and scams from northern Michigan to Malibu, California" target="_blank">Glistening, Quivering Underbelly</a></li>
<li><a href="http://www.mlpp.org" target="_blank">Michigan League for Public Policy</a></li>
<li><a href="http://michiganpoliticsonline.com/" title="Michigan progressive news and headlines" target="_blank">Michigan Politics Online</a></li>
<li><a href="http://opinionatedart.com" title="An evolving collection exploring the art of caricature, caricature artists, editorial cartoons, and political and cultural illustrations by caricature artist Donkey Hotey" target="_blank">Opinionated Art &#8211; Donkey Hotey</a></li>
<li><a href="http://www.plunderbund.com/" title="Ohio&#8217;s best state political blog" target="_blank">Plunderbund</a></li>
<li><a href="https://www.politicscentral.org/" title="Chad Selweski&#8217;s Excellent Blog" target="_blank">Politically Speaking</a></li>
<li><a href="http://www.progressmichigan.org" target="_blank">Progress Michigan</a></li>
<li><a href="http://www.ramonasvoices.com/" target="_blank">Ramona&#039;s Voices</a></li>
<li><a href="http://immasmartypants.blogspot.com" target="_blank">Smartypants</a></li>
<li><a href="http://susanjdemas.com/" title="Personal blog of Eclectablogger and journalist Susan Demas" target="_blank">SusanJDemas.com</a></li>
<li><a href="http://www.takecaretim.com/" title="Observations of the Public Record from Michigan&#8217;s 7th Congressional District" target="_blank">Take Care, Tim</a></li>
<li><a href="http://talkingpointsmemo.com/" target="_blank">Talking Points Memo</a></li>
<li><a href="http://www.msnbc.com/maddowblog" target="_blank">The Maddow Blog</a></li>
<li><a href="http://theobamadiary.com/" target="_blank">The Obama Diary</a></li>
<li><a href="http://www.thepeoplesview.net/" target="_blank">The People&#039;s View</a></li>
<li><a href="http://thinkprogress.org/?mobile=nc" target="_blank">ThinkProgress</a></li>
<li><a href="http://tressiemc.com/" target="_blank">Tressie McMillan Cottom</a></li>
<li><a href="http://www.upnorthprogressive.com/" title="News and Commentary for Northern Michigan" target="_blank">Up North Progressive</a></li>
<li><a href="http://zandarvts.blogspot.com/" target="_blank">Zandar vs. The Stupid</a></li>

	</ul>
<div class="clear"></div></div>
	
		
</div> <!-- /#sidebar --> 
		<div class="clear"></div>

		<div id="footer">

	 		<div class="column">
				<div id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="http://honeycombthepoet.com" target="_blank" title="Coming Out My Box by Tawana 'Honeycomb' Petty" rel="noopener noreferrer"><img src="http://www.eclectablog.com/wp-content/uploads/2016/12/Tawana-Honeycomb-Petty-Coming-Out-My-Box.jpg" width=225"></a>
<br/><a href="http://alswrite.com/" target="_blank" rel="noopener noreferrer"><img src="http://www.eclectablog.com/wp-content/uploads/2015/01/ALS_EclectablogAd_300x300_2015.jpg" title="Amy Lynn Smith | Writer | Strategist" width=225></a><hr></div><div class="clear"></div></div>			</div><!-- /1st column -->

			<div class="column">
				<div id="custom_html-9" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center><a href="http://www.nwu.org" target="_blank" rel="noopener noreferrer"><img src="http://eclectablog.com/wp-content/uploads/2012/06/NWUlogo.png" title="National Writers Union"></a></center>
<b>Eclectablog is a proud member of the <a href="http://www.nwu.org" target="_blank" rel="noopener noreferrer">National Writers Union (NWU)</a>.</b></div><div class="clear"></div></div>			</div><!-- /2nd column -->

			<div class="column">
				<div id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><center>Eclectablog was chosen as the <i>Washington Post's</i> <a href="http://www.washingtonpost.com/blogs/the-fix/wp/2013/03/12/the-fixs-best-state-based-political-blogs-extended-edition/">"best state-based progressive political blog"</a> for Michigan
<a href="http://www.washingtonpost.com/blogs/the-fix/wp/2013/03/12/the-fixs-best-state-based-political-blogs-extended-edition/"><br/><img src="http://www.eclectablog.com/wp-content/uploads/2013/03/BestProgBlogBadge.png" width=240 title="The Washington Post's best state based political blogs"></a></center></div><div class="clear"></div></div>			</div><!-- /3rd column -->

			<div class="column last">
				<div id="text-13" class="widget widget_text"><h3 class="title">Copyright boilerplate</h3>			<div class="textwidget"><p>Eclectablog is a project of Savage New Media, LLC.</p>
<p>All original content on this website is copyrighted © Eclectablog/Chris Savage, Anne C. Savage, LOLGOP, Mitchell Robinson, and all other content authors, all rights reserved. Unless otherwise specified, permission to excerpt <u>portions</u> of our written work is given as long as you provide a link back to this website and the appropriate author is credited. Please contact us for use of photos.</p>
</div>
		<div class="clear"></div></div>			</div><!-- /4th column -->

	 		<div class="clear"></div>

			<div id="copyright">

				Copyright &copy; 2020 &mdash; <a href="https://www.eclectablog.com" class="on">Eclectablog</a>. All Rights Reserved
				<span>Designed by <a href="https://www.wpzoom.com/" rel="nofollow" target="_blank" title="WPZOOM WordPress Themes">WPZOOM</a></span>

			</div>

		</div> <!-- /#footer -->
		<div class="clear"></div>

	</div> <!-- /.inner--wrap-->
</div> <!-- /.page-wrap-->




<!-- WP Audio player plugin v1.9.6 - https://www.tipsandtricks-hq.com/wordpress-audio-music-player-plugin-4556/ -->
    <script type="text/javascript">
        soundManager.useFlashBlock = true; // optional - if used, required flashblock.css
        soundManager.url = 'https://www.eclectablog.com/wp-content/plugins/compact-wp-audio-player/swf/soundmanager2.swf';
        function play_mp3(flg, ids, mp3url, volume, loops)
        {
            //Check the file URL parameter value
            var pieces = mp3url.split("|");
            if (pieces.length > 1) {//We have got an .ogg file too
                mp3file = pieces[0];
                oggfile = pieces[1];
                //set the file URL to be an array with the mp3 and ogg file
                mp3url = new Array(mp3file, oggfile);
            }

            soundManager.createSound({
                id: 'btnplay_' + ids,
                volume: volume,
                url: mp3url
            });

            if (flg == 'play') {
                    soundManager.play('btnplay_' + ids, {
                    onfinish: function() {
                        if (loops == 'true') {
                            loopSound('btnplay_' + ids);
                        }
                        else {
                            document.getElementById('btnplay_' + ids).style.display = 'inline';
                            document.getElementById('btnstop_' + ids).style.display = 'none';
                        }
                    }
                });
            }
            else if (flg == 'stop') {
    //soundManager.stop('btnplay_'+ids);
                soundManager.pause('btnplay_' + ids);
            }
        }
        function show_hide(flag, ids)
        {
            if (flag == 'play') {
                document.getElementById('btnplay_' + ids).style.display = 'none';
                document.getElementById('btnstop_' + ids).style.display = 'inline';
            }
            else if (flag == 'stop') {
                document.getElementById('btnplay_' + ids).style.display = 'inline';
                document.getElementById('btnstop_' + ids).style.display = 'none';
            }
        }
        function loopSound(soundID)
        {
            window.setTimeout(function() {
                soundManager.play(soundID, {onfinish: function() {
                        loopSound(soundID);
                    }});
            }, 1);
        }
        function stop_all_tracks()
        {
            soundManager.stopAll();
            var inputs = document.getElementsByTagName("input");
            for (var i = 0; i < inputs.length; i++) {
                if (inputs[i].id.indexOf("btnplay_") == 0) {
                    inputs[i].style.display = 'inline';//Toggle the play button
                }
                if (inputs[i].id.indexOf("btnstop_") == 0) {
                    inputs[i].style.display = 'none';//Hide the stop button
                }
            }
        }
    </script>
    <!-- Quantcast/Blogads Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" :
"http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-3eluKTTuZoTCU"
});
</script>


<div>
<img src="//pixel.quantserve.com/pixel/p-3eluKTTuZoTCU.gif" border="0" height="1" width="1" alt="Quantcast" />
</div>

<!-- End Quantcast/Blogads tag -->

<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-Rd3fvGDCvFRR4"
});
</script>


<div>
<img src="//pixel.quantserve.com/pixel/p-Rd3fvGDCvFRR4.gif" border="0" height="1" width="1" alt="Quantcast" />
</div>

<!-- End Quantcast tag -->

<!-- Google Analytics -->
<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-20409274-1']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
<!-- Start eXTReMe Pro Tracker Code V3/7
Login:    ectablog
Help:     https://www.extremetracking.com
Installation instructions:
Copy and paste this code between the two body tags into the
*source* of your pages or in your footer/template. Best is
to use a normal text editor such as notepad. -->
<script data-cfasync="false" type="text/javascript"><!--
EXd=document;location.protocol=="https:"?EXp="https":EXp="http";EXs="src";
EXd.write("<img "+EXs+"="+EXp+"://nht-3.extreme-dm.com/n4.g?login=ectablog",
"&url="+escape(EXd.URL)+"&jv="+navigator.javaEnabled()+"&",
"d="+screen.width+"x"+screen.height+"&c="+screen.colorDepth+"",
"&l="+escape(EXd.referrer)+" width=0 height=0>");//-->
</script><noscript><img height="1" width="1" alt=""
src="http://nht-3.extreme-dm.com/n4.g?login=ectablog&url=nojs">
</noscript>
<!-- End eXTReMe Pro Tracker Code --><script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {"passthrough":{"twitter":{"via":"Eclectablog"}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"data_ga_property":"UA-20409274-1","data_ga_social":true,"ui_atversion":"300","ui_508_compliant":true}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"sharetoolbox":{"numPreferredServices":5,"thirdPartyButtons":true,"services":"facebook_like,tweet,pinterest_pinit,counter","elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post,.at-above-post-page"}}]; } else { window.addthis_layers_tools.push({"sharetoolbox":{"numPreferredServices":5,"thirdPartyButtons":true,"services":"facebook_like,tweet,pinterest_pinit,counter","elements":".addthis_inline_share_toolbox_above,.at-above-post-homepage,.at-above-post,.at-above-post-page"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-91ac0bcc86fb3d097cd3db3ff599111c","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4f6f19b00d144e85"></script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.eclectablog.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script src="https://www.eclectablog.com/wp-content/cache/minify/0fef6.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"eclectablog"};
/* ]]> */
</script>
<script src="https://www.eclectablog.com/wp-content/cache/minify/f8767.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"71601 https:\/\/www.eclectablog.com\/?p=71601","disqusShortname":"eclectablog","disqusTitle":"Don\u2019t just praise the heroes, PAY the heroes \u2013 with special guest U.S. Senator Gary Peters","disqusUrl":"https:\/\/www.eclectablog.com\/2020\/05\/dont-just-praise-the-heroes-pay-the-heroes-with-special-guest-u-s-senator-gary-peters.html","postId":"71601"};
/* ]]> */
</script>







<script src="https://www.eclectablog.com/wp-content/cache/minify/4a689.js"></script>

<script type='text/javascript'>
/* <![CDATA[ */
var s2AjaxScriptStrings = {"ajaxurl":"https:\/\/www.eclectablog.com\/wp-admin\/admin-ajax.php","title":"Subscribe to this blog","nonce":"0bb45a7633"};
/* ]]> */
</script>









<script src="https://www.eclectablog.com/wp-content/cache/minify/6b745.js"></script>

</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Page Caching using disk: enhanced (SSL caching disabled) 
Minified using disk

Served from: www.eclectablog.com @ 2020-05-19 03:33:22 by W3 Total Cache
-->